Classic Audi Ľ Technical Ľ Mech/Tech Ľ Electrical problems » 1994 Audi Coupe 2.0e ABS issues

Reply
 
Thread Tools Display Modes
Old 09-11-18, 10:40 AM   #1
m50yre
Newbie!
 
Join Date: Sep 2017
Posts: 10
Smile 1994 Audi Coupe 2.0e ABS issues

Hi guys.
Wonder if you can help.
I have been fixing up an 80 Coupe for the past couple of years. Its now ready for MOT but i cannot get the ABS light out. Now all brakes have been removed, renewed, subframe off etc so everything is new. I cannot remember if the light was on when i got it, as it didnt run.

Ive had it on VCDS and the ABS controller cannot be communicated with.

Ive checked the ABS ECU and and got a spare to try that but makes no difference.

Only thing i can find is that the ABS ECU only gets a 6v feed - without a diagram im not sure if thats enough or if the only feed required?

Any thoughts?
m50yre is offline   Reply With Quote
Old 09-11-18, 11:07 AM   #2
Ben
4 ring whore!
Classic Audi Club Member
 
Join Date: Mar 2008
Location: Stockport
Posts: 2,011
Default

Have you checked the fuse on the ABS relay? it's located under the dash behind the ign switch:



I've had a relay die, which is why I have a photo of one
Ben is offline   Reply With Quote
Old 09-11-18, 11:16 AM   #3
m50yre
Newbie!
 
Join Date: Sep 2017
Posts: 10
Default

Hi, i saw this on another forum so went looking for that relay, but cannot find it, do all Coupes have them? Cheers
m50yre is offline   Reply With Quote
Old 09-11-18, 11:28 AM   #4
m50yre
Newbie!
 
Join Date: Sep 2017
Posts: 10
Default

IMG_0269.jpg

IMG_0270.jpg
m50yre is offline   Reply With Quote
Old 09-11-18, 11:55 AM   #5
Mellis46
Aero Advocate
Classic Audi Club Member
 
Mellis46's Avatar
 
Join Date: Aug 2014
Location: Lancashire
Posts: 1,151
Default

If its not where Ben said that ABS relay also can sometimes live under the back seat...
__________________
-1987 90 2.2E / Sapphire Blue (Rest in Pieces)
-1989 90 quattro with Sport Equipment / Satin Black
-1997 A4 Avant quattro TDI 110 / Tropical Green (Sold)
-2012 A1 Sport TFSI / Glacier White (Sold)
-2017 A1 Sportback S-line TFSI / Scuba Blue
Mellis46 is offline   Reply With Quote
Old 09-11-18, 01:22 PM   #6
Ben
4 ring whore!
Classic Audi Club Member
 
Join Date: Mar 2008
Location: Stockport
Posts: 2,011
Default

Looking through some Audi B4 pdf's, it states (for LHD):

Quote:
Removing and installing combi relay
Location:
Front left, beneath instrument panel in auxiliary relay plate
=> Current Flow Diagrams, Electrical Fault Finding; Fitting Locations
Note:
Switch off ignition for removal and installation. Not applicable as of model year 1993.
So you don't have one to check. It also says about the ABS ECU:

Quote:
Prior to removal on vehicles as of model year 1993 interrogate fault memory with fault reader -V.A.G 1551-.
I put the pdf here if you want to have a read up: http://www.brita.plus.com/80q/FWD_Running_gear.pdf right click the link to download
Ben is offline   Reply With Quote
Old 09-11-18, 01:31 PM   #7
mikes2
Senior Member
Classic Audi Club Member
 
Join Date: Nov 2007
Location: Polmont
Posts: 1,518
Default

For a 94 car, there is no relay. It's all contained in the ecu under the rear seat.

If you start the car up, the ABS light should go off within 5 seconds. If it doesn't it's likely a pump / modulator fault since you've already swapped the ecu.

There are 2 relays in the modulator which can be swapped out
__________________
1991 90 quattro 20v sport
1993 S2 estate
mikes2 is offline   Reply With Quote
Old 09-11-18, 02:22 PM   #8
m50yre
Newbie!
 
Join Date: Sep 2017
Posts: 10
Default

Thanks guys. Nah light stays on. Itís not turned a wheel for over ten years so I do wonder if once itís had a drive itíll sort itself out. Iíll keep you posted.
Cheers
m50yre is offline   Reply With Quote
Old 09-11-18, 03:03 PM   #9
Mellis46
Aero Advocate
Classic Audi Club Member
 
Mellis46's Avatar
 
Join Date: Aug 2014
Location: Lancashire
Posts: 1,151
Default

Good luck
__________________
-1987 90 2.2E / Sapphire Blue (Rest in Pieces)
-1989 90 quattro with Sport Equipment / Satin Black
-1997 A4 Avant quattro TDI 110 / Tropical Green (Sold)
-2012 A1 Sport TFSI / Glacier White (Sold)
-2017 A1 Sportback S-line TFSI / Scuba Blue
Mellis46 is offline   Reply With Quote
Old 10-11-18, 01:03 PM   #10
m50yre
Newbie!
 
Join Date: Sep 2017
Posts: 10
Default

Quote:
Originally Posted by Ben View Post
Looking through some Audi B4 pdf's, it states (for LHD):

So you don't have one to check. It also says about the ABS ECU:

I put the pdf here if you want to have a read up: http://www.brita.plus.com/80q/FWD_Running_gear.pdf right click the link to download
Thanks for the pdf. VCDS cannot read my ABS, is that normal? I had a 95 one years ago and Iím positive Vagcom could read abs on it?
m50yre is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 03:52 AM.

Powered by vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright ©2007-2008 Classic Audi | Site by Roadrunna